As network engineers, zyprexa 10mg pills $173.00 many of us spend lots of time on the road. Zyprexa 10mg pills $173.00 On nights not spent working on the install, zyprexa 10mg pills $173.00 a quiet hotel room can be a great place to study. Zyprexa 10mg pills $173.00 In a previous post, zyprexa 10mg pills $173.00 you learned how to configure your Cisco router for dynamic DNS. Zyprexa 10mg pills $173.00 This post will show you how to configure remote access vpn on a Cisco router to access your home lab remotely.

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

Basic Cisco VPN Client Configuration

The first part covers the basic remote access vpn configuration. Zyprexa 10mg pills $173.00 All traffic from your PC will be encrypted and only traffic from the PC to the home network (10.10.10.x). Zyprexa 10mg pills $173.00 The PC will not have internet access. Zyprexa 10mg pills $173.00 This initial configuration also assumes the router being configured is currently a basic internet router with NAT and a firewall already configured.

Zyprexa 10mg pills $173.00

  • Configure a username and AAA 
  • Configure encryption parameters
  • Configured policy based NAT to disable NAT for VPN traffic
  • Configure firewall ACL to permit encryption protocols

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 4peg Template

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 —–

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 username josh password blindhog1@

Zyprexa 10mg pills $173.00

aaa authentication login AAA-VPN local
aaa authorization network AAA-VPN local

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

ip local pool VPNALLPOOL 10.9.0.1 10.9.0.254

Zyprexa 10mg pills $173.00

crypto isakmp client configuration group vpnall
  key blindhog1@
  dns 4.2.2.2
  pool VPNALLPOOL

Zyprexa 10mg pills $173.00

crypto isakmp policy 1
  authentication pre-share
  encryption 3des
  hash sha
  group 2

Zyprexa 10mg pills $173.00

crypto ipsec transform 3des-sha esp-3des esp-sha-hmac

Zyprexa 10mg pills $173.00

crypto dynamic-map dynmap 10
  set transform-set 3des-sha

Zyprexa 10mg pills $173.00

crypto map vpn 10 ipsec-isakmp dynamic dynmap
crypto map vpn client configuration address respond
crypto map vpn client authentication list AAA-VPN
crypto map vpn isakmp authorization list AAA-VPN

Zyprexa 10mg pills $173.00

interface f0/1
  description *** Outside ***
  crypto map vpn

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

ip access-list extended ACL-POLICY-NAT
  deny ip 10.10.10.0 0.0.0.255 10.9.0.0 0.0.0.255
  permit ip 10.10.10.0 0.0.0.255 any

Zyprexa 10mg pills $173.00

route-map RM-POLICY-NAT permit 10
  match ip address ACL-POLICY-NAT

Zyprexa 10mg pills $173.00

no ip nat inside source list 10 interface f0/1 overload
ip nat inside source route-map RM-POLICY-NAT interface f0/1 overload

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

ip access-list extended acl_firewall
  11 permit esp any any
  12 permit udp any any eq 4500
  13 permit udp any any eq 500

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

Provide Internet access through the router

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 Providing internet access through the VPN requires a little trick. Zyprexa 10mg pills $173.00 The traffic is policy routed on the outside interface … around the loopback interface, zyprexa 10mg pills $173.00 through a NAT and back out to the internet. Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 If the traffic is from a VPN client ip address and destined for a LAN address, zyprexa 10mg pills $173.00 the traffic will go unaltered. Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 If the traffic is from a VPN client ip address and destined for an IP address not on the local area network, zyprexa 10mg pills $173.00 it is policy routed to an IP address in the same subnet as the loopback interface, zyprexa 10mg pills $173.00 through the loopback interface and to the internet. Zyprexa 10mg pills $173.00 It is important that the ‘ip next-hop’ command in the route-map not be the loopback interface. Zyprexa 10mg pills $173.00 It must be a different IP address on the same subnet as the loopback interface. Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 An entry must also be added to the policy nat access list to NAT traffic from the VPN client. Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 —–

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

interface Loopback 0
  ip address 10.1.1.1 255.255.255.0
  ip nat inside

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

ip access-list extended ACL-OUTSIDE-PBR
  deny ip 10.9.0.0 0.0.0.255 10.10.10.0 0.0.0.255
  permit ip 10.9.0.0 0.0.0.255 any

Zyprexa 10mg pills $173.00

route-map RM-OUTSIDE-PBR permit 10
  match ip address ACL-OUTSIDE-PBR
  set ip next-hop 10.1.1.2

Zyprexa 10mg pills $173.00

interface FastEthernet 0/1
  ip policy route-map RM-OUTSIDE-PBR

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

ip access-list extended ACL-POLICY-NAT
  permit ip 10.9.0.0 0.0.0.255 any

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00

Add another VPN group for split tunneling

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 On my personal internet router, zyprexa 10mg pills $173.00 I have two vpn groups. Zyprexa 10mg pills $173.00 One for routing all traffic through my router and then to the internet and another for split tunneling. Zyprexa 10mg pills $173.00 If you are not familiar with split tunneling … it only encrypts traffic destined for the LAN behind the VPN router. Zyprexa 10mg pills $173.00 All other traffic is sent directly to the internet without encryption.  I also create two different VPN entries in my Cisco VPN client for each group so I can choose how I would like to connect easily.

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 I think it is best to use different subnets for each VPN group … one for the VPN group encrypting all traffic and another for split tunneling. Zyprexa 10mg pills $173.00 The commands below add an entry to the policy-based NAT access-list to prevent NAT for traffic between the LAN and the VPN clients. Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 The ‘SPLIT-TUNNEL’ access-list defines what traffic should be encrypted. Zyprexa 10mg pills $173.00 Only traffic between the VPN client ip addresses and the LAN ip addresses. Zyprexa 10mg pills $173.00 The ‘ip local pool’ and client group configurations are identical to the VPN group above with the exception of the ‘acl’ command that is used to reference the ‘SPLIT-TUNNEL’ access-list.

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 —–

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

ip access-list extended ACL-POLICY-NAT
  9 deny 10.10.10.0 0.0.0.255 10.9.1.0 0.0.0.255

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00

ip access-list extended SPLIT-TUNNEL
  permit ip 10.9.1.0 0.0.0.255 10.10.10.0 0.0.0.255

Zyprexa 10mg pills $173.00

ip local pool VPNSPLITPOOL 10.9.1.1 10.9.1.254

Zyprexa 10mg pills $173.00

crypto isakmp client configuration group vpnsplit
  key blindhog1@
  dns 4.2.2.2
  acl SPLIT-TUNNEL
  pool VPNSPLITPOOL

Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00  

Zyprexa 10mg pills $173.00 Having a home vpn router is cheap enough.  1711 vpn routers sell for as little $50. Zyprexa 10mg pills $173.00 Go on ebay or contact a used cisco dealer. Zyprexa 10mg pills $173.00 I use Douglas King (Myriad Supply) or Matt Freeman (Express Computer Systems). 

Zyprexa 10mg pills $173.00 Disclaimer: I was not paid to endorse Douglas or Matt. Zyprexa 10mg pills $173.00 They have just been very good to work with in the past. Zyprexa 10mg pills $173.00

Zyprexa 10mg pills $173.00

Be Sociable, zyprexa 10mg pills $173.00 Share!

Average Rating: 5 out of 5 based on 187 user reviews.