This tutorial is a continuation of the virtual voice lab series. Unfortunately, the virtual voice lab has been a “work in progress” much longer than I had hoped it would be when I started it two years ago. In this tutorial, you will add a new router to your GNS3 topology. It will connect it to the HQ, BR1 and BR2 routers to simulate an Internet connection and the Public Switched Telephone Network (PSTN).

 

There is one caveat to this PSTN simulation… GNS3/Dynamips is not capable of simulating traditional analog or digital circuits. We will be simulating an Internet Telephony Service provider (ITSP). ITSPs have become increasingly popular in the past ~5 years. Basically, the PSTN router will route incoming calls to the branch routers and received outgoing calls from the branch routers over a SIP or H323 trunk.

 

Placing the “PSTN” router in the topology and configuring IP addressing will simulate an Internet connection for the branches but it is just the first step.  The call routing will be accomplished using the Cisco Unified Border Element (CUBE … formerly IPIPGW) feature or H323 Gatekeeper in other tutorials. As a side note, VPN’s and other technologies can be tested with the simulated Internet we created.

 

 

 

 

Here are the steps:

  1. Add a router to the GNS3 topology.
    You will need an IOS image on the router that supports CUBE, Gatekeeper or both.
  2. Change the hostname e.g. “pstn_internet” (optional)
  3. Add an NM-16ESW module to the new router
    1. Right-Click on the new router and configure
    2. Click the ‘Slots’ tab
    3. Add an NM-16ESW module to the router

     

  4. Connect the following interfaces to the existing branch routers
    • pstn_internet f0/0 -> Port 5 on the HQ Switch
    • pstn_internet f1/0 -> f0/1 on HQ Router
    • pstn_internet f1/1 -> f0/1 on BR1 Router
    • pstn_internet f1/2 -> f0/1 on BR2 Router

     

  5. “pstn_internet” router config changes interface f0/0
    no shutdown
    description *** Internet ***
    ip address 10.10.10.253 255.255.255.0

     

    interface f1/0
    no shutdown
    description *** HQ Internet ***
    ip address 12.34.56.1 255.255.255.252

     

    interface f1/1
    no shutdown
    description *** BR1 Internet ***
    ip address 23.45.67.1 255.255.255.252

     

    interface f1/2
    no shutdown
    description *** BR2 Internet ***
    ip address 34.56.78.1 255.255.255.252

    ip route 0.0.0.0 0.0.0.0 10.10.10.254

     

  6. “HQ” Router config changes interface f0/1
    no shutdown
    description *** Internet ***
    ip address 12.34.56.2 255.255.255.252

     

    ip route 0.0.0.0 0.0.0.0 12.34.56.1

     

  7. “BR1″ Router config changes interface f0/1
    no shutdown
    description *** Internet ***
    ip address 23.45.67.2 255.255.255.252

     

    ip route 0.0.0.0 0.0.0.0 23.45.67.1

     

  8. “BR2″ Router config changes interface f0/1
    no shutdown
    description *** Internet ***
    ip address 34.56.78.2 255.255.255.252

     

    ip route 0.0.0.0 0.0.0.0 34.56.78.1

     

Be Sociable, Share!